Forums

Steam stuck on updating

Super Street Fighter IV Arcade Edition Steam Version

Auteur Réponses
doaN Vendredi 28 Février 2014 à 5:59
doaNAnonymous

Hey guys!

Trying to install SF IV.
Everytime I tried, steam is stuck when it needs to update the first time (around 70%-90%).

I read about Steam is broken with older wine versions. Is it the cause ?
And I saw that SF IV need a special wine's version: "1.5.4-xliveless3-rawinput3"

Thanks for help
petch Vendredi 28 Février 2014 à 7:21
petch
Développeur

doaN Jeudi 6 Mars 2014 à 3:20
doaNAnonymous

hi petch and thanks.

Do I still need the xliveless3-rawinput3 version with a wine version 1.7.+ ?

Regards.
petch Jeudi 6 Mars 2014 à 3:42
petch
Développeur

I'm not sure, my best guess would be: rawinut no (I think it's now standard), xliveless yes
se99paj Jeudi 6 Mars 2014 à 12:27
se99pajAnonymous

Don't know if this is relevant, but I'm just moving over to Linux for gaming and I'm also trying to get Steam installed for the first time.

I've installed POL, and installed Steam straight from the POL options, but when I run Steam I get an error regarding SteamConfigServers not being available and Steam closes.

Not many results for SteamConfigServers on Google, I did notice that 1.7+ is required and changed in POL but this didn't help.

I'm new to POL so this could be related or I could just be installing Steam in the wrong way.
se99paj Jeudi 6 Mars 2014 à 22:44
se99pajAnonymous

For info - just found a few other people on the Steam forums that are having a similar issue as me, sure the problem is on the Steam end and is nothing to do with POL.

Looks like I picked the wrong time to start messing around with Steam and Linux
twotwenty Vendredi 7 Mars 2014 à 8:56
twotwentyAnonymous

I am having the same issue using wine1.7.13 or 1.7.*

no SteamConfigServers
I use ubuntu12.04 64bit and 4.2.2 POL

I get the same issue when trying to install in wine with a 32bit prefix

winetricks did install it and it worked in a 64bit prefix but installing .net wasd not possible so I could not install skyrim
twotwenty Vendredi 7 Mars 2014 à 9:13
twotwentyAnonymous

I was able to fix my issue by
clicking the congfigure botton used teh wine tab and uninstalled the non working steam
downloading the steam installer .exe from the steam website then running that installer using the configure button on the steam prefix in POL
in the misculaneos tab you can run .exe in this virutual drive



doaN Dimanche 9 Mars 2014 à 7:27
doaNAnonymous

petch,

How do I use a xliveless version ?
Do I need winetricks ?

Thanks.
petch Dimanche 9 Mars 2014 à 10:33
petch
Développeur

It's not a component it's a patch, so having it for Wine 1.7.x would require a build request.

I don't know the details of what version of xliveless patch to use, as I don't play anything having DRM on it (including no Steam game).
petch Dimanche 9 Mars 2014 à 11:17
petch
Développeur


The current way of requesting a custom build is to fill a feature request in the bug tracker, with a link to the patch and any relevant informations for building, specially if not standard.

See for example http://www.playonlinux.com/en/issue-1645.html