Forums

Problem with King's Bounty drive

Auteur Réponses
Jump to the page: 1 - 2
mozo Samedi 4 Octobre 2014 à 16:26
mozoAnonymous

Hello, at first I appologise for my english, I'm from Bulgaria and english is not my native language. I have problems creating King's Bounty The Legend drive. I'm starting POL, choose Install a program, find King's Bounty via search bar and select it. A popup comes in with some explanations and invite me to click Next. On the next screen there is a warning not to choose checkbox for DirectX installation from the installer of the game. By clicking next again it says "Please wait while virtual drive is being created..." and it takes forever. I tried to left it for over two hours but nothing. My specs are:

CPU: 3770.

16Gb of RAM.

Nvidia GTX 560 Ti with the latest drivers.

Arch Linux 3.16.3 with KDE.

POL version 4.2.5.

 

I can't manage to understand how to get debug output for this problem. Thank you in advance and have a nice day.

 

Edit:

Here is the terminal output&

 

[mozo@mozo ~]$ playonlinux
Looking for python... 3.4.2 - skipped
Looking for python2.7... 2.7.8 - selected
[main] Message: PlayOnLinux (4.2.5) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/mozo/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: List is up to date
[POL_GPG_auth_script] Message: Checking signature of /home/mozo/.PlayOnLinux//install
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Bash] Message: POL GPG : Good signature - King's Bounty: The Legend
--2014-10-25 17:42:33--  http://upload.wikimedia.org/wikipedia/en/3/38/King%27s_Bounty.jpg
Resolving upload.wikimedia.org (upload.wikimedia.org)... 91.198.174.208, 2620:0:862:ed1a::2:b
Connecting to upload.wikimedia.org (upload.wikimedia.org)|91.198.174.208|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 70407 (69K) [image/jpeg]
Saving to: ‘/home/mozo/.PlayOnLinux//tmp/leftnotscaled.jpeg’

100%[=========================================>] 70,407      --.-K/s   in 0.09s   

2014-10-25 17:42:33 (781 KB/s) - ‘/home/mozo/.PlayOnLinux//tmp/leftnotscaled.jpeg’ saved [70407/70407]

[POL_SetupWindow_Init] Message: Creating new window for pid 3659
[POL_SetupWindow_install_wine] Warning: Function deprecated
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.1.37, x86
[Use_WineVersion] Warning: Function is deprecated. Use export WINEVERSION instead
[select_prefixe] Warning: Deprecated function ! Use POL_Wine_SelectPrefix
[POL_SetupWindow_prefixcreate] Warning: Very deprecated ! Use POL_Wine_PrefixCreate
[POL_Wine_PrefixCreate] Message: POL_WINEVERSION is already set to 1.1.37. Using it
[POL_Wine_PrefixCreate] Message: Creating prefix (1.1.37)...
[POL_Wine_PrefixCreate] Message: Using wine 1.1.37
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.1.37, x86
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.1.37
/usr/share/playonlinux/lib/scripts.lib: line 957: lsb_release: command not found
[POL_Wine] Message: Running wine-1.1.37 --version (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
/home/mozo/.PlayOnLinux/wine/linux-x86/1.1.37/bin/wineprefixcreate
ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
err:process:__wine_kernel_init boot event wait timed out
wine: Module not found
err:process:__wine_kernel_init boot event wait timed out
/home/mozo/.PlayOnLinux/wine/linux-x86/1.1.37/bin/wineserver

 

My full specs are:

 

CPU: Intel 3770

MB: ASUS P8Z77-V

GPU: ASUS GTX 560 Ti

RAN: 16Gb Kingston HyperX@1866

Arch Linux 3.17.1

KDE 4.14.2

Edité par mozo

mozo Jeudi 16 Octobre 2014 à 21:39
mozoAnonymous

The problem still persists sad

mozo Mercredi 22 Octobre 2014 à 11:54
mozoAnonymous

Thank you for your kind help. Magnificint forum :)

Retro Gamer Samedi 25 Octobre 2014 à 5:19
Retro Gamer

I hate it when I don’t get replies to my questions either if only just to be acknowledged. There might a slight language barrier here, but I wish to help if possible. I don’t know your level of computer savviness, but your running arch so you must have some. smiley

I don’t have that game, but lets root out the obvious questions.

Do you have enough hard drive space where you're trying to install it?

Have you installed anything else with POL in this system?

If so was that successful?

 

I have never had a virtual drive take more than a few minutes to be created and the game to be installed. Right off the bat that sounds fishy. Even Skyrim with all the DLC’s took me slightly less than 30 minutes running similar hardware to yours.


If you haven’t already you should Run playonlinux from the terminal then follow the POL installer for your game. Watch the terminal for any errors or warnings as it works. Give it a good 30 minutes and if it seems again like its taking too long then just copy the text from the terminal and paste it here in this forum thread you created so we can look through the output and try to figure out where its messing up.

Edité par Retro Gamer



"..So long and thanks for all the fish."
mozo Samedi 25 Octobre 2014 à 17:16
mozoAnonymous

Hello, thanks for your answer :)

 

Yes, I have enough drive space. Yes, I have installed many workjing applications. The problem is only with King's Bounty The Legehd drive.

 

Thank you for your suggestion to run POL from terminal. It shows a bunch of errors. I can't find the code tag and I afraid to post the whole output just like that, but here it is:

[mozo@mozo ~]$ playonlinux
Looking for python... 3.4.2 - skipped
Looking for python2.7... 2.7.8 - selected
[main] Message: PlayOnLinux (4.2.5) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/mozo/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[maj_check] Message: List is up to date
[POL_GPG_auth_script] Message: Checking signature of /home/mozo/.PlayOnLinux//install
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Bash] Message: POL GPG : Good signature - King's Bounty: The Legend
--2014-10-25 17:42:33--  http://upload.wikimedia.org/wikipedia/en/3/38/King%27s_Bounty.jpg
Resolving upload.wikimedia.org (upload.wikimedia.org)... 91.198.174.208, 2620:0:862:ed1a::2:b
Connecting to upload.wikimedia.org (upload.wikimedia.org)|91.198.174.208|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 70407 (69K) [image/jpeg]
Saving to: ‘/home/mozo/.PlayOnLinux//tmp/leftnotscaled.jpeg’

100%[=========================================>] 70,407      --.-K/s   in 0.09s   

2014-10-25 17:42:33 (781 KB/s) - ‘/home/mozo/.PlayOnLinux//tmp/leftnotscaled.jpeg’ saved [70407/70407]

[POL_SetupWindow_Init] Message: Creating new window for pid 3659
[POL_SetupWindow_install_wine] Warning: Function deprecated
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.1.37, x86
[Use_WineVersion] Warning: Function is deprecated. Use export WINEVERSION instead
[select_prefixe] Warning: Deprecated function ! Use POL_Wine_SelectPrefix
[POL_SetupWindow_prefixcreate] Warning: Very deprecated ! Use POL_Wine_PrefixCreate
[POL_Wine_PrefixCreate] Message: POL_WINEVERSION is already set to 1.1.37. Using it
[POL_Wine_PrefixCreate] Message: Creating prefix (1.1.37)...
[POL_Wine_PrefixCreate] Message: Using wine 1.1.37
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.1.37, x86
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.1.37
/usr/share/playonlinux/lib/scripts.lib: line 957: lsb_release: command not found
[POL_Wine] Message: Running wine-1.1.37 --version (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
/home/mozo/.PlayOnLinux/wine/linux-x86/1.1.37/bin/wineprefixcreate
ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
err:process:__wine_kernel_init boot event wait timed out
wine: Module not found
err:process:__wine_kernel_init boot event wait timed out
/home/mozo/.PlayOnLinux/wine/linux-x86/1.1.37/bin/wineserver


And here it hangs. I left it for an hour, but nothing. I'm with SSD, so this time must be enough I think. I tried to resolve this problem:

/home/mozo/.PlayOnLinux/wine/linux-x86/1.1.37/bin/wineprefixcreate
ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

 

I dowgraded pulseaudio and libpulse to 4.0.6 - nothing. I removed them - the same picture. For the other errors I have not idea...

 

 

Edité par mozo

petch Samedi 25 Octobre 2014 à 18:40
petch
Développeur

Wine 1.1.37 is like, utterly outdated. Most likely the install script has not been updated in ages (just checked: it probably hasn't been updated in almost 5 years).

I may be better to try to install the game without it (plain Install > install non-listed program), or better yet that someone updates the script.

 

Ronin DUSETTE Samedi 25 Octobre 2014 à 18:46
Ronin DUSETTE
Admin

I would like to add that if you post your complete debug output and full computer specs in the first post, people will tend to volunteer their time to troubleshoot the issue quicker. :)


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
mozo Samedi 25 Octobre 2014 à 19:09
mozoAnonymous

 

Wine 1.1.37 is like, utterly outdated. Most likely the install script has not been updated in ages (just checked: it probably hasn't been updated in almost 5 years).

I may be better to try to install the game without it (plain Install > install non-listed program), or better yet that someone updates the script.

 

 

Edité par mozo

Retro Gamer Samedi 25 Octobre 2014 à 20:10
Retro Gamer

I’m currently at work right now, but from your output its choking on this, “Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so”

 

That’s actually a known issue with arch, pulse and older wine versions, but only documented in a few forum posts I found from the past 4 months or so. In most cases that library is there, but not being read or detected for whatever reason IDK. If downgrading as you did didn’t fix it then I’ve read people with that issue have used the system installed wine instead of the wine version suggested by the POL install script. So do as you did previous, run playonlinux from the terminal, run the King’s Bounty install script, but choose other wine version and then pick System (which as of now is 1.7.29) for wine version not the 1.1.37(VERY OLD, less compatible).

 

Don’t wait any longer than 15 minutes, if it stops on the same error then its not going any farther than that anyway.

 

Lets see how it works this time for you. If you have any issues just post the terminal output in here again.


Good luck!

Edité par Retro Gamer



"..So long and thanks for all the fish."
mozo Samedi 25 Octobre 2014 à 20:18
mozoAnonymous

Thank you for reply!

POL don't give me an option to choose from different versions when I use King's Bounty's script or I don't know how to do it :(

Ronin DUSETTE Samedi 25 Octobre 2014 à 20:23
Ronin DUSETTE
Admin

@retro - You cannot choose a different one in the install. The script's Wine version is static.

You can install different versions of Wine in:

PlayOnLinux -> Tools -> Manage Wine Versions

Install the different wine versions that you want there, and then you can apply that Wine version by:

PlayOnLinux -> Configure -> select the virtual drive -> select Wine version from dropdown menu

You cannot change it before install, though. What you can do, if you want to test it, is either do a manual install, or copy/paste the install script to a file, change the wine version in the script, save, and then run:

PlayOnLinux -> Tools -> Run a local script

and select your custom script. If you can give us working Wine version, I will go ahead and make the change to the script and get that fixed for you. 

Edité par RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
mozo Samedi 25 Octobre 2014 à 20:29
mozoAnonymous

I know how to install a different version of Wine, but with the King's Bounty there is no such an option :)

 

 

You cannot change it before install, though. What you can do, if you want to test it, is either do a manual install, or copy/paste the install script to a file, change the wine version in the script, save, and then run:

PlayOnLinux -> Tools -> Run a local script

and select your custom script. If you can give us working Wine version, I will go ahead and make the change to the script and get that fixed for you. 

 

Where can I get this script from? I can edit it, but I don't know where can I obtain it from .

 

Edité par mozo

Ronin DUSETTE Samedi 25 Octobre 2014 à 20:37
Ronin DUSETTE
Admin

 

I know how to install a different version of Wine, but with the King's Bounty there is no such an option :)

I know. That is what I am saying; the prebuilt install scripts use one, and only one version of Wine. You cannot change it. 

 

From where I can get this script? I can edit it, but I don't know from where I can obtain it

I don't know what you mean. Simply copy and paste the script from here:

http://www.playonlinux.com/en/app-520-Kings_Bounty_The_Legend.html

and paste it into a blank file (Make sure you don't copy the line numbers.), change the version of Wine in the WINEVERSION variable, save it, and run it like I said. 

I have to be honest, the installer script is 4 years old, and will need to be reworked by someone and resubmitted for approval. It uses many things that are old, not used anymore, or just not in-line with our scripts. haha. 

If you want to start testing it, and get a new/updated script for it, please do so and submit it. You can read the scripting docs here:

http://www.playonlinux.com/en/documentation.html


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Retro Gamer Samedi 25 Octobre 2014 à 20:44
Retro Gamer

 

Yeah I don't use the POL scripts all to much so thank you for that info. I see someone asking questions, having issues with no reply and I just want to help in any way I can. I know you volunteer your time here so thank you for finally stepping in and helping me help himcool

 

@retro - You cannot choose a different one in the install. The script's Wine version is static.

 



"..So long and thanks for all the fish."
Ronin DUSETTE Samedi 25 Octobre 2014 à 20:46
Ronin DUSETTE
Admin

lol. No prob. 

PS: I am a HUGE Hitchhiker's Guide fan.  I have a cat named Dougie (from South Park), but I always call him Douglas Adams. :D


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Samedi 25 Octobre 2014 à 20:50
Ronin DUSETTE
Admin

PPS: The POL scripts rock. They only suck when we don't get bug reports saying that they are broken. haha. Properly maintained scripts are pure bliss. The script API is pretty robust. What really ends up breaking a lot of them are MMORPG's and games that get updated frequently, as they can break Wine support, requiring a change of Wine version or a patch, which we never know until people report it. haha.

Bugs are a good thing, in that regard, just because we now know there is an issue, and we can try to implement a fix. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Retro Gamer Samedi 25 Octobre 2014 à 21:31
Retro Gamer

 

Great name for him..lol! I would of named our cat Trillian, but we let our son name her.

 

lol. No prob. 

PS: I am a HUGE Hitchhiker's Guide fan.  I have a cat named Dougie (from South Park), but I always call him Douglas Adams. :D

 



"..So long and thanks for all the fish."
mozo Samedi 25 Octobre 2014 à 21:51
mozoAnonymous

I tried with the latest version of Wine and it worked!!! Thank you!!!

Edité par mozo

Ronin DUSETTE Samedi 25 Octobre 2014 à 21:59
Ronin DUSETTE
Admin

Ok. I will make the change. Try to reinstall it using the automated installer in about 5 minutes. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Samedi 25 Octobre 2014 à 22:01
Ronin DUSETTE
Admin

It should be good. Hit the "refresh" button in the install window and try to reinstall it using the automatic installer. It is updated to use the newest version of Wine. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts