PoL Don`t work on Debian Lenny

Auteur Réponses
hashedone Samedi 3 Mai 2008 à 10:36

I have a little problem - today I've upgraded my Debian Lenny and I got a suprise - PoL was`t installed in my computer. I tried to install it, but it's depending old package - python version 2.5 or earlier (Lenny installing python version I tried to install older python by hand but it was too much problems to do it. Now I`m downgrading system to Etch, but I think that it isn`t good way becouse Lenny is the most used Debian version.

Edité par hashedone

Quentin PÂRIS Samedi 3 Mai 2008 à 20:59
Quentin PÂRISAnonymous

It's working on my lenny. Did you add the wx repository ?
volvox Samedi 31 Mai 2008 à 20:10

I have the same problem on my Debian lenny box. Package PlayOnLinux_3.0.1.deb depends on python-wxgtk2.8 (from wx repo) which depends both on python >= 2.4 and python < 2.5. There is only 2.5.2-1 version of python.

$ wget
$ wget -qO - | apt-key add -
$ echo 'deb etch-wx main' >> sources.list
$ aptitude update
$ aptitude install unzip wine xterm python python-wxgtk2.8 imagemagick cabextract lzma
$ dpkg -i PlayOnLinux_3.0.1.deb
skkayman Dimanche 1 Juin 2008 à 9:47

the same problem here..

$ sudo apt-get install python-wxgtk2.8
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-wxgtk2.8: Depends: python (< 2.5) but 2.5.2-1 is to be installed
E: Broken packages

$ cat /etc/apt/sources.list
deb lenny main contrib non-free
deb-src lenny main contrib non-free

deb lenny/updates main contrib
deb-src lenny/updates main contrib

deb lenny main
deb-src unstable main contrib non-free
deb etch-wx main
deb stable non-free
deb ./

GNU_Raziel Dimanche 1 Juin 2008 à 10:37


deb etch-wx main


deb gutsy-wx main

and this will do the trick

Edité par GNU_Raziel

skkayman Dimanche 1 Juin 2008 à 16:20

Thanks! It helped ;)

Finally I can install PlayOnLinux
$ sudo dpkg -i PlayOnLinux_3.0.1.deb
Selecting previously deselected package playonlinux.
(Reading database ... 409261 files and directories currently installed.)
Unpacking playonlinux (from PlayOnLinux_3.0.1.deb) ...
Setting up playonlinux (3.0.1) ...

shadow-catcher Lundi 1 Juin 2009 à 19:08

GNU_Raziel, Thank You! That was really helpful!