Diablo 3 2.4.3 patch

Unexpected Error

Auteur Réponses
PVversion666 Mercredi 11 Janvier 2017 à 4:48

Ever since the new patch, an unexpected error occurs after clicking Play.

If you would like, I can post a screen cap



RavonTUS Mercredi 11 Janvier 2017 à 18:21


Blizzard introduced a new 64-bit client with its latest update 2.4.3.  I have not been able to get it to work so far.

Try switching back to the 32-bit client.  On the screen, click the "gear" icon next to options and move the mouse down a little.  A list should appear.  Go to settings and in that menu you should see the option to run as 32-bit click.

If that doesn't help, pictures are always good.



PVversion666 Jeudi 12 Janvier 2017 à 5:24

Edité par PVversion666

PVversion666 Jeudi 12 Janvier 2017 à 5:39

I found the gear on the main page (the games page, top left side marked Options)

The box that has the option, Launch 32-bit client (instead of 64-bit), is grayed out. I don't have the option to check or uncheck it. 

PVversion666 Dimanche 15 Janvier 2017 à 8:40

Edité par PVversion666

tprestegard Jeudi 19 Janvier 2017 à 15:05

Hey! I created a POL account just to reply to you since I was having the same problem and found a solution for me on Ubuntu 16.04.  In the end, I just had to upgrade the Wine version that my installation was using.  Previously I was on wine 1.9.18, and I upgraded to 1.9.24 and the problem was solved.

In POL, you can go to Tools -> Manage Wine versions to install 1.9.24. Then click on your program, then Configure (in the left panel), and change the Wine version.  Hope that helps!

PVversion666 Lundi 23 Janvier 2017 à 7:05

That worked beautifully! Thank you so much for going through all that trouble!


PVversion666 Samedi 15 Juillet 2017 à 7:22

I'm getting an error again, and am wondering if this is the same thing as before, or if this is a different error. When I try to launch the blizzard app, an error window pops up.