Howto configure network printer if POL doesn't pick up CUPS

Auteur Réponses
kaimon Dimanche 5 Novembre 2017 à 20:27

OS debian stretch, POL 4.2.12, CUPS installed, printing to PDF or network works flawlessly under linux

I have a POL wine prefix where whenever I print to PDF the program hangs and wine crashes and whenever I print to the network printer everything proceeds but just nothing arrives at the printer. It used to work before I moved, which involved changing the printers network adress and updating from jessie to stretch. I think that somehow the print config of POL got lost, the Windows printing output seems to end up in nirwana. I need to repair this prefix because I don't have the installation files for this old Win prog anymore.

Questions about troubleshooting printing problems have been asked before but were never answered, all links just refer to "configure the linux printing system correctly and wine will pick up on it" - but this is obviously not true in all cases. Wine docs say that you need to configure printers in the spool section of .winerc but I can't find a file of that name on my system. says there is a ~/.wine/win.ini file with this configuration but it is also missing on my system.

So where does POL store the printer conf or the link to the hosts printing subsystem?


Edité par kaimon

kaimon Dimanche 5 Novembre 2017 à 23:09

In order to further troubleshoot I created a new 32bit prefix and added a starter for wordpad. In wordpad print dialog the network printer showed up with the remark "Ready .... WINEPS Printer using LPR", but printing did nothing. Cups pdf printer entry was missing, there was an lp option instead.

I created a new 64bit prefix and tried wordpad again. This time PDF printer showed up as well (the lpr option vanished). Printing resulted in an empty page, on the network printer and on PDF.

The important prefix I need to get to work is 32bit.

Edité par kaimon

kaimon Vendredi 4 Janvier 2019 à 8:57

Problem is solved, see the solution here:

litaamethyst Jeudi 21 Décembre 2023 à 10:29

I was using POL (Printer Options Locator) to set up my network printer, relying on its user-friendly interface to seamlessly integrate with CUPS (Common UNIX Printing System). However, to my surprise, POL wasn't picking up CUPS, causing a bit of frustration in the process.

see this here

check my site


This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to