Risk II freezes in battle

Auteur Réponses
trymeout Lundi 26 Aoüt 2019 à 17:27


I got Risk II installed but it will freeze during the first, second or third battle and I would need to press Alt+F4 to close the game and fix my resolution. I tried using wine 2.14-staging, 2.20, 4.0.1 and 4.10 but I still get the same result. The ufile link is a my POL log file and this is the errors I am getting. What libaries am I missing and how do I fix it?


0036:fixme:gstreamer:event_src 0x66c34c90 (61441) stub
0036:err:gstreamer:unknown_type Could not find a filter for caps: "audio/x-wav"
0009:err:gstreamer:GST_Connect GStreamer failed to play stream
0037:err:gstreamer:watch_bus decodebin1: Your GStreamer installation is missing a plug-in.
0037:err:gstreamer:watch_bus gstdecodebin2.c(4679): gst_decode_bin_expose ():
no suitable plugins found:
Missing decoder: WAV (audio/x-wav)

Dadu042 Lundi 26 Aoüt 2019 à 19:39

What is your OS and version ?


You will find the answer on the web by searching "gstreamer install wav codec"

trymeout Lundi 26 Aoüt 2019 à 21:48

Do I need to install the codecs in the POL virtual drive or on my linux system?

trymeout Dimanche 1 September 2019 à 0:27

I tried installing GStreamer by following this tutorial for linux by installing these libaries below and I also tried installing the windows installer within the wine prefix and I still have no luck.

sudo apt-get install libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio

Dadu042 Dimanche 1 September 2019 à 19:59

> Do I need to install the codecs in the POL virtual drive or on my linux system?


On your linux system.


Sorry I can't provide support about Gstreamer.

Edité par Dadu042