Forums

Wine version selection not working?

Auteur Réponses
eqisow Samedi 4 Juillet 2009 à 19:33
eqisowAnonymous

I'm trying to get the Sims 3 working with PlayOnLinux (like everybody else, apparently). I get the following error when it runs:

ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 135 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x21
Serial number of failed request: 444
Current serial number in output stream: 444

Citer
However, I think it's trying to run it in the system version of wine, 1.1.23. I've selected 1.1.24-TheSims3 as the version for TS3 and even set it to the default, but when I pull up winecfg under "Configure This Application" it says 1.1.23 in the About tab. Is this normal?

As far as the error, it looks 3D related, but I have the nvidia drivers installed, direct rendering, and glxgears/compiz working.
NSLW Samedi 4 Juillet 2009 à 21:45
NSLW

Do you have got what is mentioned here? Particularly point 2a
eqisow Samedi 4 Juillet 2009 à 21:50
eqisowAnonymous

Yes.

As i said, compiz runs, glxgears runs, direct rendering is on, and all of my native games run. The game has the no-cd patch as well. The video memory is wrong, but I can't fix it. I have 890MB of video RAM, but only 768 and 1GB are options, with no way that I see to make a custom entry.

What about the winecfg about page still saying 1.1.23 when I ahve 1.1.24-TheSims3 selected? Is that normal?

Edité par eqisow

Aymeric P. Dimanche 5 Juillet 2009 à 7:56
Aymeric P.
Admin

've selected 1.1.24-TheSims3 as the version for TS3 and even set it to the default, but when I pull up winecfg under "Configure This Application" it says 1.1.23 in the About tab. Is this normal?

Citer

Yes, winecfg use the system version.

When you set the video RAM set it to 768.
Disable compiz

Try with Wine 1.1.25 (will be available in about 4 hours) :|

Former member.
NSLW Dimanche 5 Juillet 2009 à 12:32
NSLW

The video memory is wrong, but I can't fix it. I have 890MB of video RAM, but only 768 and 1GB are options, with no way that I see to make a custom entry.

Quote from eqisow

Once I was told that Wine won't use all graphic memory card so it was no bad thing to set 768 However i fixed that in The Sims 3 script.

As MulX said, try Wine 1.1.25, now it doesn't need any patches to not crash after a while.

BTW. Do you've got 64 bit OS?
eqisow Dimanche 5 Juillet 2009 à 20:28
eqisowAnonymous

Yes, I'm running 64bit Fedora 11. The video memory is set to 768 and I'm using 1.1.25 now. I've also tried with compiz disabled with the same result.

Also interested, but probably not relevant, is the ALSA error. When using foobar2000 in wine, sound works... so I'm not sure what that's about.

Edité par eqisow

NSLW Dimanche 5 Juillet 2009 à 20:42
NSLW

Yes, I'm running 64bit Fedora 11.

Quote from eqisow

If you do have got 64 bit OS then you must have got 32 bit graphic drivers for Wine. Do you've got one?
The same problem was here somewhere on forum.
eqisow Lundi 6 Juillet 2009 à 6:37
eqisowAnonymous

How on earth do you install 32 bit drivers on a 64 bit kernel?

Edit: Never mind, it just needs the 32bit gl library. That's xorg-x11-drv-nvidia-libs for Fedora users with nvidia cards.

Thanks for the help!

Edité par eqisow