Forums

Installation Topsolid 2009

En toute légalité...

Auteur Réponses
bobfred Jeudi 6 Aoüt 2009 à 10:27
bobfredAnonymous

Bonjour,

je suis nouveau sous "PlayOnLinux" et j'aimerais passer complètement mon poste de travail sous Ubuntu Studio 9.04 pour à la fois pouvoir faire de la zique mais aussi travailler...

Je suis dessinateur indus. et je bosse avec "Topsolid 2009". Ce dernier utilisent certaines fonctions supplémentaires que je ne sais pas installer. J'ai réussi hier à faire fonctionner le "Viewer" avec l'affichage OpenGL OK. Mais Topsolid ne démarre pas! Voici ce qui me manque :

- Microsoft .NET Framework 2.0
- Microsoft Visual C++ 2005 Redistributable
- Microsoft Visual C++ 2008 Redistributable
- Sentinel Protection Installer 7.4.0 ou 7.5.0

Tous ces outils sont fournis dans le CD d'install mais plantent à l'install.

Je sais que dans "Winetricks" les 3 premier existent et peuvent s'installer. Seraient-ils fonctionnels dans une install via "PlayOnLinux"?

Merci pour votre aide.
@+, Fred
Si non, comment faire pour les installer via "PlayOnLinux" et que Topsolid puisse fonctionner
BlondVador Jeudi 6 Aoüt 2009 à 13:05
BlondVador
Modérateur

Bonjour,

Vous pourrez installer Microsoft .NET Framework 2.0 avec PlayOnLinux (Installer --> Autre). Cependant les autres dépendances ne sont pas disponibles directement via POL.

Vous pourrez malgré tout installer Microsoft Visual C++ 2005 Redistributable en suivant ceci :
http://appdb.winehq.org/objectManager.php?sClass=version&iId=15312&iTestingId=36214

Ainsi que Microsoft Visual C++ 2008 Redistributable :
http://appdb.winehq.org/objectManager.php?sClass=version&iId=15313&iTestingId=36215

Je n'ai malheureusement pas trouvé pour Sentinel Protection Installer 7.4.0 ou 7.50.

Autrement la version 2007 semble fonctionner via Wine malgré que ce ne soit pas la version que vous recherchiez.

Edité par BlondVador


bobfred Jeudi 6 Aoüt 2009 à 13:28
bobfredAnonymous

Merci,

je vais installer Ubuntu Studio cet aprem et je ferai un test. Est-ce que de tout installer via "Winetricks" est une bonne solution?

@+, Fred
BlondVador Jeudi 6 Aoüt 2009 à 14:23
BlondVador
Modérateur

Winetricks réalise, d'après moi, des installations moins "propres" que PlayOnLinux. Je ne pense pas que ce soit une bonne ni une mauvaise solution. C'est une solution.

L'important est que ça fonctionne non ? ;)

bobfred Jeudi 6 Aoüt 2009 à 14:53
bobfredAnonymous

Oui,

ca y est, je suis sous ubuntu!!!

Donc, si j'ai bien compris la philo de "PlayOnLinux", à chaque install d'une appli on crée une instance de windows. Je m'explique, j'ai vu que pour installer DOTNet 2.0, il faut lui indiquer un conteneur qui crrespond au nom de l'appli installée. Mais si j'installe un driver pour l'ensemble de Wine, est-il pris en charge par l'applie installée sous "PlayOnLinux"?

Je ne dois pas être très clair, mais c'est parceque je débute avec wine!!!

@+, Fred
BlondVador Jeudi 6 Aoüt 2009 à 18:31
BlondVador
Modérateur

En gros, tu veux dire que si tu installes un programme sans PlayOnLinux, les apllications de POL en profiteront-elles ?

Et bien la réponse est non.

En gros PlayOnLinux crée "un wine pour une appli". Chacune des applications possède sa propre configuration de Wine, indépendament du Wine que tu as installé hors POL.

J'éspère avoir répondu à ta question.

bobfred Vendredi 7 Aoüt 2009 à 7:40
bobfredAnonymous

Salut et merci,

je commence à mieux comprendre.

J'ai besoin d'installer "MS Installer 3.1" et ce dernier plante à l'install. Y a t-il un moyen de l'installer via ton "PlayOnLinux?

@+, Fred
bobfred Vendredi 7 Aoüt 2009 à 7:42
bobfredAnonymous

Du reste je n'arrive pas à installer "Microsoft Visual C++ 2008 Redistributable" ni même" Microsoft Visual C++ 2008 Redistributable SP1"!
bobfred Vendredi 7 Aoüt 2009 à 8:43
bobfredAnonymous

Quand je veux installer ces 2 dernières applis, j'ai le message suivant :

"Unable to find a volume for file extraction.
Please verify that you have proper permissions."

Y aurait-il un dossier à débloquer?

@+, Fred
ddelec24 Vendredi 7 Aoüt 2009 à 12:27
ddelec24

Tu as un lien "éditer" à côté de la date du post, merci de l'utiliser plutôt que faire un double post.


Pour ce qui est de ton problème, quelle méthode utilises-tu? installer dans un prefixe existant? autre?

merci de préciser comment tu t'y prend pour savoir si il n'y a pas une erreur à ce niveau là je pense que le prefixe n'est pas sélectionné comme il faut...

- venez sur irc!