Forums

MAJ ubuntu karmic vers Lucid : Wine= plus de pilote Esound !!!

Auteur Réponses
Sylvain_07 Mercredi 19 Mai 2010 à 0:10
Sylvain_07Anonymous

Bonjour,
depuis que j'ai fais ma mise à jours de ubuntu karmic vers lucid :
je pilote esound n'est plus disponible :

lorsque je fait configurer wine onglet audio :

j'ai un message qui me dit que le pilote Esound à été trouvé dans la base de registre mais qu'il n'est pas disponible et me demande si je veus le suprimé.

si je clik sur non et que j'arrive dans les propirétés audio : je n'ai plus le pilote Esound

j'ai essayer de le supprimer et de le réinstaller toujours le me problème.
le problème c'est que je n'ai plus de sont sur certain jeu qui ne ponctionnés qu'avec se pilote :
-Civilization 4 BTS
- et le jeu de ma copine : Kindergarden

si ej configure ses 2 jeu en pilote alsa: le son coupe, gresille et j'ai de l'écho comme si certain son étaient joué plusieurs fois.

c'est vraiment dommage car avec la version 1.1.44 le son marche trés bien en alsa avec trackmania united forever ( qui ne marchait pas jusque là)

mais avec la mise à jour de karmic vers lucid j'ai fait un pas en arrière.

(:sad: la prochaine fois je me précipiterais moins pour faire les maj)

une solution mis à part réinstaller karmic?
Quentin PÂRIS Jeudi 20 Mai 2010 à 20:52
Quentin PÂRIS
Admin

Faut regarde si t'as pas un plugin esound pour pulseaudio (Essais d'installer pulseaudio-esound-compa)
Sylvain_07 Mercredi 26 Mai 2010 à 22:47
Sylvain_07Anonymous

merci de ta réponse, à priori j'ai déjà ce paquet d'installé:
"Version\\u00a0: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14 (pulseaudio-esound-compat)"



Sylvain_07 Vendredi 28 Mai 2010 à 20:34
Sylvain_07Anonymous

Merci de votre aide,
problème résolut en installant la version 1.023 d'ALSA en place de la version native 1.021.

à priori je ne serais pas le seul à souffrir de se genre de problème avec ubuntu Lucid.

voici la méthode pour installer la version 1.023
http://monespaceperso.org/blog/2010/05/02/mise-a-jour-de-alsa-1-0-23-sous-ubuntu-lucid-lynx-10-04/


Quentin PÂRIS Vendredi 28 Mai 2010 à 22:34
Quentin PÂRIS
Admin

Merci pour la solution :)
Sylvain_07 Vendredi 11 Juin 2010 à 23:43
Sylvain_07Anonymous

Aprés quelque jours,
je viens confirmé et apporter des nouveaux élément.

donc pour ce qui est de la mise à jours d'alsa vers la dernière version : ça donne de trés bon résulats :un son parfait et pas de bug du son, ni de ralentissement dans le jeu .
seul inconvéniant : il faut réinstaller la version d'alasa à chaque mise à jours du noyau sinon plus de son ni dans ubuntu ni dans wine.
la réinitialisation d'alsa ne suffit pas : il faut sere taper la procédure d'instalation ( donc n'effacer pas les fichier d'instalation trop vite)

donc maintenant open AL semble bien gérer
par contre j'ai supprimé les fichier Openal du répertoire du jeu pour n'utiliser que ceux qui son dans wine car il m'a semblé ressentir quelques petit ralentissement avec les fichier du répéertoire du jeu. j'imagine que ceux de wine doivent être plus à jours.

sinon j'ai aussi peu être une autre info pour ceux qui comme moi resentent le sintome du jeu qui fige plusieur secondes ou plusieurs minutes ( ne répond plus)
et qui on ceci dans leur gestionaire de tache :
http://marcon.sylvain.perso.sfr.fr/Image/Processus.jpeg

aprés plusieur semaine à chercher le problème est la solution :
j'ai comme qui dirait l'impression que le problème viens des locators.
genre dans la course un joueur à un skin qui pointe vers un locator obsoléte ou encombré et on se retrouve un peut avec le me syntomne de la page plage dans le navigateur lorsque l'on pointe sur un site out et le jeu ne répond plus et attend

en désactivant les locator et leur mise à jours il semblerai ( à confirmé) que l'on n'ai plus se soucis de jeu qui fige.
les skin des circuits et véhicules sont un peut plus long à venir mais la solution semble efficace est moins radicale que de désactivé pure et simplement le P2P

à suivre

Edité par Tinou