Forums

Mount and Blade Warband

Auteur Réponses
Jump to the page: 1 - 2
Deleted account Vendredi 31 Décembre 2010 à 1:46
Deleted accountAnonymous

Bonjour, je voulais savoir s'il etait possible de créer un script pour Mount and Blade Warband, j'ai vu qu'il y avait moyen de faire tourner le single player assez facilement, mais qu'il y avait d'autres soucis du coté du multiplayer, et puis, avec playonlinux, c'est tellement plus facile pour les neophites comme moi :incertain:
D'autre part, s'il y avait moyen de faire ceci, est-ce que les mods du jeux pourraient fonctionner eux aussi? (En sachant qu'il ne s'agit en général que de changements de type skins des soldats, des maps ou des sons).
Merci.

Edit: Tout pour faire fonctionner le jeu semble être là http://forums.taleworlds.com/index.php/topic,99405.90.html, mais bon, l'anglais et moi... :sad:

Edité par Deleted account

Salvatos Vendredi 31 Décembre 2010 à 3:57
SalvatosAnonymous
Modérateur

En attendant, si tu veux que je te traduise quelque chose, suffit de demander. Si le premier message du sujet cité suffit à la tâche, c'est effectivement très simple.

Disclaimer: I'm a noob, not a dev; my advice is only a guess.
Attention : Je suis aussi noob que vous, prenez mes suggestions avec un grain de sel ;)
Quentin PÂRIS Vendredi 31 Décembre 2010 à 11:52
Quentin PÂRIS
Admin

Par contre, par pitié, faite un effort sur le forum dans lequel vous postez ...
SuperPlumus Vendredi 31 Décembre 2010 à 15:05
SuperPlumusAnonymous
Admin

Bonjour,

D'après les informations que j'ai pu trouvé, et avec le lien que tu a donné, j'ai fait un script pour installer Mount&Blade : Warband.

Il se trouve dans la catégorie "Applications en test" de PlayOnLinux, tu peux l'essayer, et donner tes commentaires au sujet du script (fonctionne/fonctionne pas).

Ne connaissant pas le jeu, je ne peut pas le tester.

Pour les mods, il faudrait que j'ai plus d'informations.

Edité par SuperPlumus

Deleted account Vendredi 31 Décembre 2010 à 21:54
Deleted accountAnonymous

Quand j'essaie, ça me fait un erreur "This script does not exist" :cry:
Une traduction de la marche à suivre sur le forum serait evidemment bienvenue (même si pouvoir passer par l'application de playonlinux me plairait mieux je crois :P).
Désolé pour la mauvaise section :x

Edité par Deleted account

SuperPlumus Samedi 1 Janvier 2011 à 6:17
SuperPlumusAnonymous
Admin

C'est corrigé, tu peux l'installer via PlayOnLinux -> Installer -> Applications en test -> Mount and Blade : Warband.

Edité par SuperPlumus

Deleted account Dimanche 2 Janvier 2011 à 15:36
Deleted accountAnonymous

Merci bcp, le jeu fonctionne! Par contre, y a plusieurs soucis, la musique du jeu est saccadé, la souris fonctionne seulement si elle le veut (des fois, pas moyen de faire un tour complet, d'autres, elle fonctionne plus du tout) puis dans les menu, elle est pas précise, elle sélectionne pas ce qui a sur sa pointe mais une case plus haut. Quand je clique sur configurer au debut, j'ai juste droit au changement de langue et quelques autres trucs, normalement y a d'autres réglages possibles (comme passer du directx 7 au 9 par exemple). Le multi j'ai pas encore pu tester.
SuperPlumus Dimanche 2 Janvier 2011 à 17:35
SuperPlumusAnonymous
Admin

Content que ça marche à peu près correctement.

Pour la souris, c'est un bug de Wine, à plusieurs endroits j'ai lu que en mettant la sensibilité de la souris dans le jeu à fond, le problème était réglé, c'est donc ce que le script PlayOnLinux fait automatiquement lors de l'installation.

Pour les paramétrages, certains peuvent être modifiés sur la première fenêtre avant que le jeu démarre (comme la version de DirectX, par exemple), pour les autres, c'est dans le jeu directement.

Pour le son, les réglages sont fait par le script PlayOnLinux d'après les informations que j'ai pu trouvées. Soit le problème vient du fait que ce sont des mauvais réglages, ou alors cela vient de ton ordinateur. Tu peux faire un clic droit sur le jeu dans PlayOnLinux, puis cliquer sur "Configurer Wine", puis essayer de modifier des réglages dans l'onglet audio pour voir si ça va mieux.

Si avec certains réglages, le jeu fonctionne mieux, précise lesquels dans ce sujet, afin que je puisse modifier le script si nécessaire.
Deleted account Dimanche 2 Janvier 2011 à 17:46
Deleted accountAnonymous

Pour la souris, j'avais remarqué que la sensibilité était au maximum au début, c'est vrai que y avait pas de problèmes, mais c'était tellement sensible que c'en était presque injouable. Pour DirectX, justement, les réglages n'apparaissent pas à la première fenêtre chez moi :s.
Quoi qu'il en soit, encore merci, j'peux enfin dégommer des rhodoks à l'arbalète comme sur l'autre "os" :D

Edité par Deleted account

SuperPlumus Dimanche 2 Janvier 2011 à 18:25
SuperPlumusAnonymous
Admin

Pour la souris il serait bien que tu me dise à quel niveau tu l'a réglé à peu près, afin que je puisse modifier le script pour que ce ne soir pas "injouable".

Pour DirectX, c'est bizarre, tu n'a pas l'onglet "Vidéo" dans la première fenêtre, car moi je l'ai ?

Pour le son, est ce que tu a pu régler ton problème ?

En tout cas je suis heureux de pouvoir t'aider.

Edité par SuperPlumus

Deleted account Dimanche 2 Janvier 2011 à 20:22
Deleted accountAnonymous

Pour la souris, je l'ai juste mis à un peu plus de la moitié.
Pour DirectX, je vais tenter une réinstallation du jeu, on sait jamais, j'ai pas cet onglet Video :s
Pour le son, j'avais pensé avoir réglé le problème en passant l’accélération matérielle en "emulation" à la place de "complète" mais après un autre essai, j'avais de nouveau le son saccadé. J'ai essayé OSS, ESD et NAS, rien n'y fait. J'ai donc juste couper la musique.
Par contre, y a quelques minutes, alors que je m’apprête à attaquer quelques brigands, wine me dit qu'il y a eu une erreur et qu'il faut quitter, sais pas d'où ça vient :/
thuban Dimanche 15 Mai 2011 à 11:33
thuban

Perso je n'ai aucun souci, voici les réglages que j'utilises :
- directx9 et pas le 7 utilisé par défaut par le script
- wine en version 1.3.20
- le jeu en plein écran sur un second serveur X

Avec ça, le jeu tourne bien, avec quelques rares bugs venant de wine. Je n'ai pas le souci de la souris qui refuse de faire plus de 180° depuis que j'utilise directx9.

Edité par thuban

thuban Lundi 16 Mai 2011 à 13:38
thuban

Je viens de tester pour voir comment passer à côté du bug de la souris. En fait, il n'est nullement besoin de directx9 à la place du 7, mais simplement de wine en 1.3.20 .

Et en plus, le jeu ne rame pas avec directx7. Il serait bon de mettre le script à jour pour utiliser cette version, non?
Tutul Mercredi 18 Mai 2011 à 9:49
Tutul
Modérateur

Sur POM on a également le problème avec la souris mais ton script fonctionne à merveille :D

Sinon, a quant wine 1.3.20 sur POM pour pouvoir jouer correctement :laught:

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
thuban Jeudi 19 Mai 2011 à 20:53
thuban

Le 1.3.20 est dispo tu sais! Et comme ça, plus de soucis avec la souris (wahou, méga top!)
Tu vas dans outils -> Gérer les versions de wine
Dans les versions dispo, tu choisis la 1.3.20, puis clique sur le bouton Ajouter.
Ensuite, tu passes dans l'onglet "mes applications", et attribue la version 1.3.20 à mount and blade.
Donc en attendant que le script intègre par défaut la dernière mouture de wine, il suffit de faire comme ci dessus.
Tutul Jeudi 19 Mai 2011 à 21:43
Tutul
Modérateur

Le 1.3.20 est dispo tu sais!

Quote from thuban

Pas sur POM :p

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
thuban Vendredi 20 Mai 2011 à 10:03
thuban

Ah pardon, j'avais cru lire POL (playonlinux) au lieu de POM :s
SuperPlumus Mardi 24 Mai 2011 à 5:04
SuperPlumusAnonymous
Admin

Je mettrai la version de Wine du script à 1.3.20 dès que cette version sera sortie sur PlayOnMac.
Tutul Mardi 24 Mai 2011 à 20:39
Tutul
Modérateur

Se serait après Samedi (Tinou s'en charge) :-°
J'ai hate de jouer à Mount & Blade Warband sans problème de souris :D

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Tutul Samedi 28 Mai 2011 à 12:25
Tutul
Modérateur

1.3.20 disponible sur POM !!!!

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !