Diablo 3 kills network connection

hangs at about 25-26%

Auteur Réponses
Goddard Vendredi 18 Mai 2012 à 3:49

When trying to install Diablo 3 I get about 25% through the install process and my connection speed goes from about 7Mbps to 0 and then totally kills my network connection all together.  I had to restart to fix it.  I tried several times with the same result.

Asus G73JW ROG-A3B7M

Intel Core i7 || 16GB RAM || 802.11n+BT || 2 x 500GB Hybrid Drives || Nvidia GTX 460M

Ubuntu 12.04 upgraded from 11.10

I know its possible to get this sucker working as I have seen plenty of videos, but I've been waiting on playonlinux because wine is to confusing.

I already have Diablo 3 installed on a seperate drive running windows.  Can I just use that installation source some how?

Thanks ALOT!

Edité par Goddard

Clicksights Vendredi 18 Mai 2012 à 4:13

The POL install works perfect!
I used my Diablo III CE DVD, just had to:

sudo umount /dev/sr0
sudo mkdir /media/Diablo3
sudo mount /dev/sr0 /media/Diablo3 -o unhide,unhide,uid=$(id -g)

And installed in a breeze!
Before on a friends laptop (on windows) we had to try it 2 days long and wait over 9 hours, the servers of blizzard are overloaded, have patience, follow the POL instructions and it will work ok.
Goddard Vendredi 18 Mai 2012 à 4:21

Appreciate the kind words, but not sure it is the same issue. Makes me wish I had an actual CD though.

About 3 more % after trying again my connection will probably be cut off.

Edité par Goddard

Clicksights Vendredi 18 Mai 2012 à 4:37

Ow man, i totally missed you are on Ubuntu 12....
I dowgraded a friend his install today, it works OK on 11.10,
not sure on 12.04... Last time i heard it was not supported...
Maybe upgrade to 12.10 or downgrade to 11.10 again...

Personally i think It's worth to downgrade after 12 years of waiting, i would know where my prio would be... :-P Not on Ubuntu 12...

Hope it works out for you, maybe try the irc, maybe some one is able to help...

Clicksights Vendredi 18 Mai 2012 à 4:42

Found this on

Ubuntu 12.04 people who are not able to connect, please run the following command:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope

Just copy it in a terminal (CONTROL + ALT + T) and retry!
Hope it works!
Goddard Vendredi 18 Mai 2012 à 5:21

I got it working.

I had to repeatedly "Enable Networking" and "Disable Networking" to get the network connection to resume downloading.

When I got to the login screen that command you gave me helped. I was getting a 3007 error.

Now it works perfectly although the game does seem to make my PC run hot. Kind of makes me worried.

Whats your gamertag?  Lets play D3!!!!

Edité par Goddard