Forums

Diablo 3

Auteur Réponses
pharyon Lundi 28 Mai 2012 à 10:14
pharyonAnonymous

Version de Wine : 1.5.4-diablo3
Distribution : Ubuntu 64bit
Version de la distribution : 12.04 (Precise)
Carte graphique : ATI Radeon HD 6800
Pilote de carte graphique : 8.96
Commentaires :

Installation via le script PoL sans soucis, utilisation nécessaire de la commande pour passer la vérification à la connexion :
"echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope".

Interface, son, vidéo : OK, les vidéos semble très pixelisé. A voir sur une installation W7 (à venir) pour comparer.

Le jeux est parfaitement jouable. Pendant 1 heure j'ai traversé le début du jeu sans artefact graphique ou bug. Le framerate me semble un poil bas (tout les paramètres en 'haut' sauf les ombres en 'moyen'.



Edité par pharyon

pharyon Mercredi 13 Juin 2012 à 8:07
pharyonAnonymous

Ça a marché, je ne sais trop ce qui a changé mais ce n'est plus le cas.

Le jeux freeze au bout de quelques secondes après la connexion, que ce soit dans l'écran de création de personnage ou en plein début de jeu.

Pas de modification de wine ou de config pourtant...

en mode debug je termine sur cette ligne :

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier
winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
err:winediag:shader_generate_glsl_declarations The hardware does not support enough uniform components to run this shader, it may not render correctly.

Edité par pharyon

pharyon Vendredi 22 Juin 2012 à 8:18
pharyonAnonymous

Cf ce bug : http://bugs.winehq.org/show_bug.cgi?id=30920
Il semble que les possesseurs de carte ATI soit bloqués par ce bug. Donc rien à voir avec POL.

Edité par pharyon

Quentin PÂRIS Vendredi 22 Juin 2012 à 8:24
Quentin PÂRIS
Admin

Il faut utiliser la dernière version de wine Diablo IIII avec les derniers drivers. (10.6)
gartrog Samedi 23 Juin 2012 à 12:14
gartrogAnonymous

Ouiiiiiiin !

Je viens de l'installer, le launcher me dit que le jeu est à jour, mais quand j'arrive sur l'écran principal il me dit qu'il faut patcher le jeu, et il quitte automatiquement.

J'ai pourtant la dernière version de Wine indiquée (la diabloIII-V3)

Y a-t-il une solution ?

S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.
Riusma Mardi 26 Juin 2012 à 10:49
RiusmaAnonymous

Bonjour, tout d'abord merci pour Play On Linux, j'ai pu installer sans souci Diablo III (malgré un téléchargement du jeu depuis BattleNet un peu longuet du fait d'une connexion poussive). Le jeu tourne nickel avec Ubuntu 12.04 - 64 bit, PoL 4.1.2 (même avec la version un peu datée disponible dans les dépôts officiels d'Ubuntu), Wine 1.5.5-diabloIII-v3 et avec un Intel® Core™2 Quad CPU Q9550 @ 2.83GHz × 4 et une GeForce 9800 GX2/PCIe/SSE2... J'ai juste des crash complets avec reboot dès que je joue un peu trop longtemps (parfois faut vraiment pas jouer longtemps) qui me semblent plutôt dus à une alimentation un peu juste au niveau Watt (il y a tout un topic à ce sujet sur les forums de Blizzard, et cette explication me semble la plus raisonnable parmi celles proposées par les intervenants de ce topic). Je vais changer d'alim mais du coup j'ai quand même quelques question de néophyte :

* démarrer avec une session Unity 2D représente-t-il un gain sensible par rapport à une session Unity 3D (notamment vis-à-vis de la consommation de la carte graphique)... au niveau de la mémoire vive je gagne 500 Mo, mais j'ai pas mal de marge à ce niveau là de toute manière (6 Go de Ram)

* y-a-t-il besoin d'installer des paquetages supplémentaires (comme proposé dans le menu de configuration de PoL), ou ceux-ci ne sont proposés que "au cas où" et la configuration par défaut se suffit à elle-même ?

Merci encore ! :)

Edit : je confirme que les crashs étaient dus à l'alimentation (j'avais une 550 W de basse qualité, remplacée par une 750 W de marque), maintenant tout roule parfaitement ! :)

Edité par Riusma

lacton Samedi 7 Juillet 2012 à 18:51
lactonAnonymous

Version de PoL : 4.1.3
Version de Wine : wine-1.5.5-DiabloIII_v3
Distribution : Mandriva
Version de la distribution : 2011.0 (Official) for i586
Carte graphique : ATI Radeon HD 4870
Pilote de carte graphique : fglrx 8.951
Commentaires : Installation OK, démarrage OK, freeze à la connexion

L'installation et le lancement de Diablo III se passent parfaitement. Par contre, après avoir saisi mon nom de compte et mon mot de passe, quand je clique sur le bouton Connexion, le jeu se fige irrémédiablement.

Dans playonlinux.log, je vois à ce moment-là :

Handle Event: "auth validation event"
Removing uri "/update/diablo3_frfr" since it has no process interested in it.
Request Issued: DELETE /update/diablo3_frfr
Database Remove: /update/diablo3_frfr
Queue 'async_task' Resource for delete
Deferred delete of 'async_task' Resource
Handle Event: "auth validation evenfixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub

Je vois mentionner au début du fil de discussion l'instruction "echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope", mais ma distribution linux ne propose ce fichier. En fait, je n'ai même pas de répertoire yama dans /proc/sys/kernel.

Problème connu, il faut mettre à jour les drivers

Edité par Tinou

lacton Dimanche 8 Juillet 2012 à 14:18
lactonAnonymous

Tinou, merci pour ton feedback.

A quels drivers tu fais référence ? Il y a une URL qui en parle ?
Quentin PÂRIS Dimanche 8 Juillet 2012 à 15:17
Quentin PÂRIS
Admin

Oui sur le forum anglais, merci d'ouvrir un sujet dans le forum PlayOnLinux si nécessaire pour ne pas encombrer les tests
Papynerds Vendredi 31 Aoüt 2012 à 19:19
PapynerdsAnonymous

Bonjour a vous tous,

Version de PoL : 4.1.7
Version de Wine : wine-1.5.11
Distribution : Ubuntu
Version de la distribution : aucune idée installé hier et mise à jour de suite ^^
Carte graphique : ATI Radeon HD 6870
Pilote de carte graphique : je sait pas j'ai juste mis a jour avec les pilotes propriétaire
Commentaires : Installation OK, démarrage OK, jouabilité ok mais...

Toujours obligé a chaque connexion de passer par le terminal pour passer la vérification :
"echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope"

Après, je peut jouer, je me ballade partout et soudainement, blocage, plus rien ne bouge, cela peut m'arriver a peine 30 secondes après la connexion, comme cela peut m'arriver après une séance de 30 mn. Est ce que ça vous arrive aussi ?.

Je suis un grand débutant sous linux, j'arrive a jouer a wow sans passer par POL juste en lançant sous wine, c'est pourquoi je n'ai pas installé le wine diablo3.
Dois-je l'installer obligatoirement la version diablo de wine ? et si oui, quelqu'un peut m'expliquer un peu de A à Z comment procéder pour garder le wine qui va bien pour wow aussi ... ou la version diablo de wine ne changera rien pour WoW ?

Si quelqu'un pouvait me venir en aide cela me serait d'un grand secours.

Merci d'avance.
Vous êtes ici: Index > PlayOnLinux > Diablo 3