Problem with Launcher from Star Wars The Old Republic


Auteur Réponses
damarus Mercredi 11 Juillet 2012 à 21:07

First, Hello :D
I need help.
My Launcher from STWOR is Black and i can do nothing.
Look at this Link, that's is my Desktop:

- Name of the distribution : Ubuntu 12.04 
- Name of the software and its version : Star Wars The Old Republic (Wine Version: 1.5.1-old_republic)
- My desktop: Xcfe (Xubuntu)
- Errors from the software: I don't Know. It's only Black (see the Link)
- Asus X52J:
Cpu Intel Core i7 740QM / 1.73 GHz
Graphic AMD Radeon HD 6370M

damarus Vendredi 13 Juillet 2012 à 12:16

And now i have a new Problem.
By Guild Wars 2.The Client canceled the download by 4% and than came a errorreport from Arenet. When i started the Download new, it beginns from new. (Sorry my Englisch is bad)
The problem also exists in Windows, see the link:
pls i need help
edusong Dimanche 15 Juillet 2012 à 7:45

Hi guys.

Same problem here.

 - Ubuntu 12.04
 - Pentium i7
 - gforce gtx 460
 - 6gb ram


[07/15/12 02:41:17] - Running wine-1.5.1-old_republic launcher.exe (Working directory : /home/edd/.PlayOnLinux/wineprefix/SWTOR/drive_c/Program Files/Electronic Arts/BioWare/Star Wars - The Old Republfixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias 180, std (d/m/y): 26/02/2012, dlt (d/m/y): 21/10/2012
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/ /usr/lib/i386-linux-gnu/pkcs11/ Não é possivel abrir arquivo de objetos compartilhado: fixme:iphlpapi:NotifyAddrChange (Handle 0x32e5a4, overlapped 0xa09b40): stub
fixme:winsock:WSALookupServiceBeginW (0x32e5c8 0x00000ff0 0x32e5c4) Stub!
[0715/] WSALookupServiceBegin failed with: 8
fixme:wininet:query_global_option INTERNET_OPTION_PER_CONNECTION_OPTION stub
fixme:wininet:InternetSetOptionW Unhandled dwOption 3
fixme:wininet:InternetSetOptionW Option 95 STUB
fixme:wininet:InternetSetOptionW Option 39 STUB
fixme:wininet:InternetSetOptionW Option 37 STUB
fixme:advapi:RegisterTraceGuidsW (0x1047c680, 0x111ac364, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x1117cadc, (null), (null), 0x111ac37c,): stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded

Any idea? I just tried to run the launcher with wine 1.5.8, and got the same error.


Edité par edusong

Armadillos Mardi 17 Juillet 2012 à 5:53

I also have this issue with the Old Republic.
ulkesh Jeudi 19 Juillet 2012 à 1:05

I, as well, have this issue. AMD Radeon HD 5770 with Ubuntu 12.04
edusong Dimanche 22 Juillet 2012 à 7:59

Hi guys, i bring news.

If you guys set a virtual desktop in wine (1000 x 614 magic numbers), we will be able to see launcher fine, but play the game in that resolution is terrible. Anyway, im trying to find a better solution.

Good luck!!!
GNU_Raziel Dimanche 22 Juillet 2012 à 12:21

Thx for the reports, I will check this as soon as possible and see if I can fix this issue.


Armadillos Dimanche 22 Juillet 2012 à 20:19

Once you get past the launcher, you should be able to change your resolution in the game to what you want it to be, and it will resize the virtual desktop for you.
edusong Dimanche 22 Juillet 2012 à 22:03

Once you get past the launcher, you should be able to change your resolution in the game to what you want it to be, and it will resize the virtual desktop for you.

Quote from Armadillos

Wow, thank you...setting in game to 1440x900 resized que virtual desktop....thank you again =)