StarCraft II Wings of Liberty

Författare Svar
Jump to the page: 1 - 2
GNU_Raziel Friday 6 August 2010 at 15:13

Wine version: 1.2
Distribution: Debian
Distribution version: Squeeze X86_64 (Testing)
Graphics card: Nvidia Geforce GTX480
Graphics card driver: 256.44
-To install the DVD version, it must be mounted using the "unhide" option, this root command is given to you but you must type it yourself.
-If you experience lags, change Textures Quality, it must match your video memory size, for example: Medium: 255 Mo.
-Disabling Reflects and reducing Shadows quality is also a very good way to boost your FPS.

Here is a preview of how it runs using the Capture plugin:


Now that we have a flawless Bug Tracker, it could be wise to use it so please, for your bug report, use our Bug Tracker now :)

Have a good game :sunglasses:

Ändrat av Salvatos

GNU_Raziel Friday 6 August 2010 at 15:58

Script has been modified to clarify DVD manipulations and prevent a bug under particular circonstances.

Ändrat av GNU_Raziel

GNU_Raziel Monday 9 August 2010 at 12:15

Script has been modified to avoid a problem with some materials, now the script copy the whole DVD files to the hard drive before installing. Be sure to have at least 19Go of free space then (7Go for DVD files and 12Go for the game). After installation, the script delete DVD files of course.
GNU_Raziel Thursday 26 August 2010 at 15:03

Ganon11 Thursday 31 March 2011 at 6:08


I just used your script to install Starcraft 2. When I run the application, I experience 2 problems:

1) Many of the images are shrunken horizontally, so that they appear very thin.
2) The mouse detection is incorrect - it detects my mouse is hovering over the QUIT button, for example, when my mouse is in fact far to the right of it.

Can you help me fix this?

Thank you.
GNU_Raziel Thursday 31 March 2011 at 20:36

Images problem seem to be ATI/AMD driver related from what I read on AppDB so i presume you're using AIT/AMD card. Did not see solution, try at least to "play" with OffScreenRenderingMode option using Advanced Wine Configuration plugin of PoL.
Never saw the second problem, try newest release of wine for this game (1.3.16) using Manage Wine Version in PoL.
stephenh Saturday 6 August 2011 at 20:27

Hi Raziel,

I'm having a problem making the installer work (digital download) using Fedora 15 and latest version of PlayOnLinux. I can't seem to avoid needing libjpeg8; which I eventually think I installed and placed into HOME/.PlayOnLinux/WineVersions/version/usr/lib as suggested by Tinou and although now it doesn't complain about not having libjpeg8 installed, it still says it's unable to start the installer.

Is there a way I can install SC2 using an older version of WINE perhaps? One that isn't prebuilt for libjpeg8? Fedora is still using 6.2 and doesn't look to change anytime soon. I'm sure this will help other Fedora users also.


Ändrat av stephenh

GNU_Raziel Sunday 7 August 2011 at 0:22

This is a Fedora related problem, I cannot help you with this since you already the faulty lib...

Try using wine 1.3.24/1.3.23 and see if it produce the same error.
ClifferBenny Tuesday 18 October 2011 at 4:36

Ubuntu 11.04 (64 bit) -
POL v.4 - Wine 1.3.30

Please help me if you can...

I installed StarCraft 2, from download, using PlayOnLinux. It seemed to install just fine. After the installation was complete, the game downloaded 21 patches, all the while saying "no problems detected." When double-clicking the "StarCraft II" icon that was put on my desktop, all I get is the waiting/busy cursor for like 10 seconds, then nothing happens. The game does not show on the little POL window either. If I click "install" again, and go back to the setup file, a SC2 window opens, telling me the game is already installed. It gives me the option to install, or to play. Choosing play, just exits and throws a Blizzard Error reporter at me. I have tried to reinstall it, but it doesn't change anything.

Serpico89 Friday 21 October 2011 at 12:28

I have the same problem. But if i open it from the PlayOnLinux's installed programs list it works fine
Maxiride Thursday 10 November 2011 at 22:43

I have correctly installed SC2 on kubuntu 11.10, pretty everything goes right but the texture.

I get screens like this ones:

Any suggestion?
GNU_Raziel Friday 11 November 2011 at 19:19

If you have ATI/AMD or Intel graphic card, it's a driver problem, not related to PoL or wine. There is nothing we can do.
DracoP Friday 6 January 2012 at 4:34

I don't know if this was addressed or not; POL installs Starcraft II perfectly, no issue with gameplay, but multiplayer does not work. Custom games, such as against the AI does not work, and even news it not loading. About the only thing that works is the campaign. Setup is 11.10 64bit, Kernel 3.0.0-14, NVidia driver 280.13, Geforce GTS 250.
bijiplay Saturday 9 June 2012 at 11:26

Starcraft II install with no problem , but when running, it failed. I'm sure it is because of wrong wine version installed (64bit) which my SC II version is 32bit.
Is there any way to change it, or installation script?
GNU_Raziel Saturday 9 June 2012 at 19:26

Our wine builds x64 run the exact same way windows x64 do for x86 softwares, so NO it's not the wine arch.

First check pol logs to identify your problem and remember this : you you try to play non-native game under GNU/Linux with ATI/AMD or Intel GMA cards, you will run into big problems/failure most of time. Only Nvidia cards run well in thoses cases.

Ändrat av GNU_Raziel

Deleted Bad topic
faerbit Wednesday 20 March 2013 at 20:35


has anyone tried the new addon with this script? (I know it says Wings of Liberty...) I getting really weird and random freezes all the time. Once it runs, it does so without any sincere problems and good fps, but getting there is very difficult. I'm not sure if it would improve the situation if I download the whole game. Currently I have only downloaded the bare minimum (Stream Installer), because of my internet speed.
Freezes occur at the following points:
At the login screen.
After login.
At the loading screen.
In the game.

Graphics: NV GF 450 GTS
OS: Archlinux with proprietary Nvidia drivers (313.26-1)

Any help would be awesome!


Cerba Monday 25 March 2013 at 11:51

Hey I have installed the game, but after the first atempt of getting throught the login the game doesn't go any furter the start clue...
krissi Saturday 6 April 2013 at 16:57

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope
did you type that in terminal to fix login crash ?
jenocrates Monday 30 September 2013 at 11:03


I have a problem with install of starcraft II with DVD, when running "wine-1.5.10 start / unix / media / cdrom / Installer.exe" PlayOnLinux gives me an access denied