wrong path, programs cannot start

Auteur Réponses
Anubis Vendredi 25 Janvier 2008 à 19:04

anubis@linux-pc:~> /usr/share/playonlinux/playonlinux --run "Notepad++"

PlayOnLinux v2.0
Checking python : [ Ok ]
Notepad++: line 4: cd: /home/anubis/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++: No such file or directory
wine: could not load L"c:\\windows\\system32\
otepad++.exe": Module not found

that's normal because the path is NOT

/home/anubis/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++



anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c> ls
Programmi windows
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c> cd Programmi
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi> ls
Common Files Internet Explorer Notepad++
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi> cd Notepad++
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi/Notepad++> ls
change.log langs.xml nativeLang.xml plugins SciLexer.dll uninstall.exe
config.xml license.txt notepad++.exe QuickText.ini shortcuts.xml
contextMenu.xml LINEDRAW.TTF nppcm.dll readme.txt stylers.xml

Edité par Anubis

Quentin PÂRIS Vendredi 25 Janvier 2008 à 19:25
Quentin PÂRISAnonymous

What version of wine are you using ?

(You are not in the right section)
Anubis Samedi 26 Janvier 2008 à 13:20

why wrong section... it looks like a bug or not?

anyway.... 0.9.53
goku Samedi 26 Janvier 2008 à 13:43

I think you have to edit the script launching notepad++ ( $HOME/.PlayOnLinux/configurations/installed/Notepad++ )

You have just to change the direction of the directory opened
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++"
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Programmi/Notepad++"

Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
Quentin PÂRIS Samedi 26 Janvier 2008 à 14:34
Quentin PÂRISAnonymous

I think it is because you have an Italien version of wine. In french or in english, it is "Program Files"
Anubis Samedi 26 Janvier 2008 à 19:29

I think you have to edit the script launching notepad++ ( $HOME/.PlayOnLinux/configurations/installed/Notepad++ )

You have just to change the direction of the directory opened
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++"
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Programmi/Notepad++"

Quote from goku
hasi Samedi 26 Janvier 2008 à 22:27

By the way, why are there two slashes between "NotepadPlusPlus" and "drive_c"?
gnud Vendredi 1 Février 2008 à 5:40

I have this same problem, because Wine respects my systems locale settings and playonlinux does not. This prevents the launcher from working, and also breaks some install scripts.

PlayOnLinux really needs a way to specify paths like "Program Files" and "Application Data" (on my computer, the names are "Programfiler" and "Fellesfiler".

I suggest that you scrape the system.reg file in a shell file that gets .source'd by all install scripts:
PROGRAMFILES="drive_c$(grep -e \"ProgramFiles\" system.reg|tr -d \"|tr = /|cut -d/ -f2 -|cut -d: -f2)"

This will give a relative path like "drive_c\\Program Files"

juancarlospaco Jeudi 22 Mai 2008 à 23:05

Hi, im from Argentina, sorry for my english...

i have the same problem installing M$ Office 2003 Spanish Version,
POL keep searching " Program Files " but the CD install it in " Archivos de Programa ".

A Script could correct this problems...? sounds easy.
thanks for all...
GNU_Raziel Vendredi 23 Mai 2008 à 8:45

we will work on a solution as soon as possible, stay tuned
meloves Samedi 24 Mai 2008 à 20:12

It should be marked as SOLVED.
juancarlospaco Samedi 24 Mai 2008 à 21:07

Thanks a lot, this is REAL support.
VeauX Mercredi 9 Juillet 2008 à 6:46

Same issue here. I have a spanish version of openSuse. programs install themselves in the ARCHIVOS DE PROGRAMA directory and the scrip calls PROGRAM FILES

Play on linux version 3.something .. sorry the about button don't work
OpenSuse 11 x86_64
wine 1.1.0
game Diablo 2 installed yesterday.(game works changing directory names)
meloves Mercredi 9 Juillet 2008 à 21:23

I second that: "I think you have to edit the script launching notepad++ ( $HOME/.PlayOnLinux/configurations/installed/Notepad++ ) "

VeauX, you should try the same thing.

Go to $HOME/.PlayOnLinux/configurations/installed/ folder and edit your scripts (i.e. change Program files to Archivos de programa).

Any questions, PM me.
VeauX Jeudi 10 Juillet 2008 à 1:20

No issue I did that and it worked like a charm. Just mentioning this as a bug because it should simply not happen... doing it each time I install somehting new is not the solution of that bug, just a countermeasure. The root cause is not solved.
Quentin PÂRIS Dimanche 14 Décembre 2008 à 16:20
Quentin PÂRISAnonymous

Since PlayOnLinux 3.1, this problem is solved.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to