Forums

Can't seem to create a virtual disk

Auteur Réponses
GabCM Mardi 8 September 2015 à 18:58
GabCMAnonymous

Hey there,

I've been trying to install Steins;Gate in my mid-2015 MacBook Pro 15" Retina. It's in the supported software list.

It seems I can't create a virtual disk so the installation can progress. It gets stuck on this step. I also notice that, in my dock, there's a Wine icon that's for installing Mono for Wine. It doesn't seem to get away from there. I could make the installation go a bit further by making the Mono for Wine installation stop, but I don't think it's a good idea.

I've also tried installing another application as well as simply creating a virtual disk (using the same Wine version) without any software. The same thing happens. That's why I've posted my thread here, as I think it's a general issue I'm having.

So yeah, I think I'm having an issue related to Mono for Wine.

Any help would be appreciated. Thank you!

OSX Version: OS X 10.11 El Capitan GM Candidate

CPU: 2.8 GHz Intel Core i7 4980HQ

Memory: 16 GB 1600 MHz DDR3

Graphics: AMD Radeon R9 M370X 2048 MB

PlayOnMac version: 4.2.8

I also have XQuartz 2.7.7 installed.

 

Here's the log

PlayOnLinux debbuging tool (v4.2.8)
-----------------------------------------------
Debugging: Steins;Gate

Warning: This is a PlayOnLinux script logfile. It does not contain everything that happened in your program\'s virtual drive (wineprefix)
Please do not use this logfile on winehq forum, this logfile is not interesting for wine debugging.

Date: 09/08/15 12:43:24

> uname -a
  Darwin Gab-Portable.local 15.0.0 Darwin Kernel Version 15.0.0: Wed Aug 26 19:41:34 PDT 2015; root:xnu-3247.1.106~5/RELEASE_X86_64 x86_64
> lsb_release -a
 
> wine --version (Be careful; this version might not be the version used
in the script. Read the content of this file for more information)
  wine-1.7.26
> glxinfo \| grep rendering
 
> glxinfo \| grep renderer
 
> OpenGL libs
 
 
> export
  declare -x AMD64_COMPATIBLE="False"
declare -x APPLICATION_TITLE="PlayOnMac"
declare -x ARGVZERO="./playonmac.real"
declare -x Apple_PubSub_Socket_Render="/private/tmp/com.apple.launchd.YcIzhBuCA5/Render"
declare -x DEBIAN_PACKAGE="FALSE"
declare -x DESKTOP="/Users/gabcm/Desktop"
declare -x DISPLAY="/private/tmp/com.apple.launchd.LVaBteF2wS/org.macosforge.xquartz:0"
declare -x DONT_MONITOR="1"
declare -x DYLDPATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applideclare -x EXECUTABLEPATH="/Applications/PlayOnMac.app/Contents/MacOS/./playonmac.real"
declare -x GECKO_SITE="http://wine.playonlinux.com/gecko"
declare -x GNUPGHOME="/Users/gabcm/Library/PlayOnMac//gpg"
declare -x HOME="/Users/gabcm"
declare -x IGNORE_ICON_DIR="false"
declare -x LANG="fr_CA.UTF-8"
declare -x LD_32_PATH_ORIGIN=""
declare -x LD_PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/lib/:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicationdeclare -x LOGNAME="gabcm"
declare -x MACHTYPE="x86_64-apple-darwin15"
declare -x MAGICK_HOME="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/"
declare -x MD5_COMMAND="md5"
declare -x MONO_SITE="http://wine.playonlinux.com/mono"
declare -x NOBUGREPORT="YES"
declare -x OLDPWD="/Users/gabcm/Library/PlayOnMac/configurations/setups/Steins;Gate"
declare -x OSX_SUB_VERSION="0"
declare -x OSX_VERSION="15"
declare -x OS_NAME="darwin"
declare -x OpenGL32="1"
declare -x OpenGL64="1"
declare -x PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/PlayOnMacdeclare -x PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/Pldeclare -x PLAYONLINUX="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"
declare -x PLAYONMAC="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"
declare -x POL_ARCH="x86"
declare -x POL_BAD_SIGNATURE="TRUE"
declare -x POL_COOKIE="lMlCXuBAC8VfBZtrsvd8"
declare -x POL_CURL="curl"
declare -x POL_DNS="playonmac.com"
declare -x POL_HOST="127.0.0.1"
declare -x POL_ID="88098044"
declare -x POL_LANG="fr"
declare -x POL_OS="Mac"
declare -x POL_PORT="30000"
declare -x POL_SetupWindow_ID="7778"
declare -x POL_TERM="xterm"
declare -x POL_UPTODATE="TRUE"
declare -x POL_USER_ARCH="x86"
declare -x POL_USER_ROOT="/Users/gabcm/Library/PlayOnMac/"
declare -x POL_WGET="wget --prefer-family=IPv4 -q"
declare -x PWD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/python"
declare -x PYTHONHOME="/Applications/PlayOnMac.app/Contents/Resources"
declare -x PYTHONPATH="/Applications/PlayOnMac.app/Contents/Resources"
declare -x REPERTOIRE="/Users/gabcm/Library/PlayOnMac/"
declare -x RESOURCEPATH="/Applications/PlayOnMac.app/Contents/Resources"
declare -x RLANG="fr_CA.UTF-8"
declare -x SCRIPTID="Steins;Gate"
declare -x SED="sed"
declare -x SETUPWINDOW_INIT="true"
declare -x SHELL="/bin/bash"
declare -x SHLVL="3"
declare -x SITE="http://repository.playonlinux.com"
declare -x SSH_AUTH_SOCK="/private/tmp/com.apple.launchd.Zc5kgSwxLC/Listeners"
declare -x TEXTDOMAIN="pol"
declare -x TEXTDOMAINDIR="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/lang/locale/"
declare -x TITLE="Steins;Gate"
declare -x TITRE="PlayOnMac"
declare -x TMPDIR="/var/folders/z8/1vxc7rm56474nhz168c3fp300000gn/T/"
declare -x USER="gabcm"
declare -x VERSION="4.2.8"
declare -x WGETRC="/Users/gabcm/Library/PlayOnMac//configurations/wgetrc"
declare -x WINEDLLOVERRIDES=""
declare -x WINEPREFIX="/Users/gabcm/Library/PlayOnMac//wineprefix/default"
declare -x WINE_SITE="http://wine.playonlinux.com/binaries"
declare -x XPC_FLAGS="0x0"
declare -x XPC_SERVICE_NAME="0"
declare -x __CF_USER_TEXT_ENCODING="0x1F5:0x0:0x1"

09/08/15 12:43:34 - [POL_Wine_SelectPrefix] Message: Selecting prefix: steinsgate
09/08/15 12:43:34 - [POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.7.15
09/08/15 12:43:34 - [POL_Wine_PrefixCreate] Message: Creating prefix (1.7.15)...
09/08/15 12:43:34 - [POL_Wine_PrefixCreate] Message: Using wine 1.7.15
09/08/15 12:43:34 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.7.15, x86
09/08/15 12:43:35 - [POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
09/08/15 12:43:35 - [POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.7.15
09/08/15 12:43:35 - [POL_Wine] Message: Running wine-1.7.15 --version (Working directory : /Applications/PlayOnMac.app/Contents/Resources/playonlinux/python)
09/08/15 12:43:35 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
wine-1.7.15
09/08/15 12:43:35 - [POL_Wine] Message: Wine return: 0

Here's the script. It's exactly the one from the supported software database.

#!/bin/bash
# Date : (2014-01-20)
# Last revision : (2014-01-20)
# Wine version used : 1.7.15
# Distribution used to test : Mac OS X 10.9.2
# Author : Marking
 
# Tested using Mac OS X 10.9.2
 
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
 
# Setup some needed variables
TITLE="Steins;Gate"
PREFIX="steinsgate"
WINEVERSION="1.7.15"
EDITOR="Nitroplus"
GAME_URL="http://steins-gate.us"
AUTHOR="Marking"
SHORTCUT_NAME="Steins;Gate"
 
# Download images for installation script
POL_GetSetupImages "http://files.playonlinux.com/resources/setups/$PREFIX/top.jpg" "http://files.playonlinux.com/resources/setups/$PREFIX/left.jpg" "$TITLE"
 
# Initialize the script and debugging
POL_SetupWindow_Init
POL_SetupWindow_SetID 1988
POL_Debug_Init
 
# Setup presentation window
POL_SetupWindow_presentation "$TITLE" "$EDITOR" "$GAME_URL" "$AUTHOR" "$PREFIX"
 
# Begin setting up the Wine Prefix
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINEVERSION"
 
# Installs components needed to install game and play movies
POL_Call POL_Install_msxml3
POL_Call POL_Install_vcrun2010
POL_Call POL_Install_d3dx9
POL_Call POL_Install_quartz
POL_Call POL_Install_wmp10
 
# Ask user for either DVD or Local installation
POL_SetupWindow_InstallMethod "LOCAL,DVD"
 
if [ "$INSTALL_METHOD" = "LOCAL" ]
then
        # Ask user to find "Setup.exe"
    cd "$HOME"
        POL_SetupWindow_browse "$(eval_gettext 'Please locate installation program (Setup.exe)')" "$TITLE"
        POL_Wine_WaitBefore "$TITLE"
        POL_Wine "$APP_ANSWER" /silent
 
elif [ "$INSTALL_METHOD" = "DVD" ]
then
        # Launches the installation program from CD/DVD
        POL_SetupWindow_cdrom
        POL_SetupWindow_check_cdrom "data.bin"
        POL_Wine_WaitBefore "$TITLE"
        POL_Wine "$CDROM/Setup.exe" /silent
fi
     
# Create a shortcut for easy access
POL_Shortcut "STEINSGATE.EXE" "$SHORTCUT_NAME" "$SHORTCUT_NAME.png"
 
POL_SetupWindow_Close
exit

Edité par GabCM

GabCM Mardi 8 September 2015 à 23:43
GabCMAnonymous

Actually, something weirder happens.

This is what Wine displays.

I can move those two little white lines if I tried hard enough. The rest of the image is my wallpaper.

Edité par GabCM

GabCM Jeudi 10 September 2015 à 6:41
GabCMAnonymous

I've just upgraded my OS X to the El Capitan GM Candidate. Same thing.

Quentin PÂRIS Jeudi 10 September 2015 à 13:57
Quentin PÂRIS
Admin

Hi,

Can you try with PlayOnLinux 4.2.9 released today?

Thanks!

GabCM Jeudi 10 September 2015 à 17:21
GabCMAnonymous

Great! I could get through the installation seeing all the windows! The update seems to have fixed that part.

Thank you!

scriscuoli Samedi 24 Octobre 2015 à 7:13
scriscuoliAnonymous

Seems I'm in the same boat. "creating virtual disk" just spins.

I have an older HP Pavilion running the nvidia 340xx drivers. I loaded both 64 and 32 bit of the x11-drv rpm and I'm running PlayOnLinux 4.2.9 already. This box is running CentOS 7.

 

I've seen this message a number of times:

 

(python:7573): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

 

 

 

petch Samedi 24 Octobre 2015 à 10:17
petch
Développeur

You're running CentOS on OS X?

Don't hijack threads.