Diablo 3 Banned for using POL

Författare Svar
DrPancake Saturday 14 July 2012 at 22:19


Yesterday I received an email from Blizzard saying my account is suspended to due hacking. So I'd like to bring this topic out here on this forum as a warning and maybe a technical discussion in order to help prevent this from happening to others. I am not expecting anything to come from Blizzard after reading numerous posts about this. I am no Linux expert, and I've tried to make the game work numerous times under Ubuntu using patches on the WineHQ website. A few weeks ago, I got the game to run flawlessly with this setup:
  PlayOnLinux 3.8.8
  wine-1.5.7 (not patched)
  Ubuntu 11.10 with kernel 3.0.0-22-generic /w the gnome-session-fallback

Using the default start-up script for POL and Diablo 3 with this modified line:
setarch i386 -3 -L -B -R wine "~/.PlayOnLinux/wineprefix/.wine/drive_c/Program Files/Diablo III/Diablo III.exe"  $@

Here's the email from Blizzard:

Like I said, I'm not a Linux guru nor am I using hacks or bots as they have blamed with the masterful QA team. I found two postings from Blizzard that confirm running it on Linux is allowed and will not get you banned... here and here.

Has anyone else had this happen to them, or know of someone who has?
petch Saturday 14 July 2012 at 22:52

That has been already discussed, check the news:
It's not a problem about using PlayOnLinux, or Wine for that matter, but for being suspected of cheating, so you have to check with their support directly.

Ändrat av petch

Quentin PÂRIS Sunday 15 July 2012 at 0:04
Quentin PÂRISAnonymous

I don't know what you did exactly, but you are definitely not using PlayOnLinux as you should.

- PlayOnLinux 3.8.8 is completely outdated (I'm really surprised to see people still using such an old version, something like more than 2 years late)
- You should not have a .wine folder into wineprefix folder
- 1.5.7 does not support D3 completely

PlayOnLinux can't be responsible if you got banned especially if you don't not use it normally.

You have probably something else in your computer that triggered their anticheat detections.

Ändrat av Tinou

DrPancake Sunday 15 July 2012 at 1:15

Thanks for the support, I'm not blaming Wine or POL, the .wine folder was created because I specified it that way. 1.5.7 is the first release to include the patches that allowed AcceptEx to work with the Blizzard installer - I've used them with Wine 1.5.4 when the first game released to get the game to work. Ubuntu still lists 3.8.8-1 in the synaptic as the latest version - I didn't go here to download the most updated as it worked with that one.

I just wanted to see if anyone else had this happen, and I doubt I'm not using POL as I should.
capman Friday 2 November 2012 at 22:47

This happend to me now too, ive tried to make blizzard belive in me but with no luck.

I know everyone says their not a cheater, but im sure there are plenty of inocent people been banned for the wrong reasons.

Im one of them....
ZKRiNG Sunday 4 November 2012 at 20:59

I play some weeks with a debian amd64 and any problem, now for a new problem with amd drivers move to ubuntu and read that...

Are you using amd64 version? You try the setarch i386 -3 -L -B -R playonlinux on every PoL start?
edusong Tuesday 6 November 2012 at 11:37

Just happend to me Friday too. Any ideas to have it back?